skip to Main Content
GNU Octave 5.1.0 Released With HiDPI Support (Howto Install)

GNU Octave 5.1.0 Released with HiDPI Support (Howto Install)


GNU Octave 5.1.0 Released with HiDPI Support (Howto Install)

GNU Octave 5.1.0 was announced yesterday as a new major release with Matlab compatibility improvements, and many new and improved functions.

GNU Octave 5.1.0 release highlights:

  • Adds HiDPI support
  • Requires Qt4 >= 4.8, though Qt5 is preferred.
  • Adds many new functions.
  • Printing to raster formats now uses an OpenGL-based method by default
  • New print options for PDF and PostScript
  • A new printing device produces ASCII art for plots
  • The FFTW library is now required for FFT calculations
  • The OSMesa library is no longer used.

How to Install Octave 5.1 in Ubuntu 18.04/16.04:

1. First open terminal (Ctrl+Alt+T) and make sure Flatpak support is enabled by running command:

sudo apt-get install flatpak

For Ubuntu 16.04, you need to add the Flatpak PPA first to be able to install Flatpak framework.

2. Then add the Flathub repository, the best place to get Flatpak apps:

flatpak remote-add –if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

3. Finally install GNU Octave from the Flathub repository:

flatpak install flathub org.octave.Octave

It will take a few minutes downloading the flatpak package as well as dependency platform if you’re first time installing it.

Like normal applications, you can launch Octave from Gnome app launcher:

The flatpak co-exists with traditional Octave package. You can alternatively run it in command line:

flatpak run org.octave.Octave

Uninstall:

You can remove the Octave flatpak package by running command:

flatpak uninstall org.octave.Octave

And remove flatpak support if you want:

sudo apt-get remove flatpak

Source: Ubuntu Handbook
GNU Octave 5.1.0 Released with HiDPI Support (Howto Install)

zhavick

Web Developer

Leave a Reply

Back To Top